天极传媒:
天极网
比特网
IT专家网
52PK游戏网
极客修
全国分站

北京上海广州深港南京福建沈阳成都杭州西安长春重庆大庆合肥惠州青岛郑州泰州厦门淄博天津无锡哈尔滨

产品
  • 网页
  • 产品
  • 图片
  • 报价
  • 下载
全高清投影机 净化器 4K电视曲面电视小家电滚筒洗衣机
您现在的位置: 天极网 > 软件 > 系统>新闻>Linux内核中的漏洞提供了非法根权限

Linux内核中的漏洞提供了非法根权限

天极网软件频道2010-09-19 07:56我要吐槽

  Linux内核中的漏洞提供了非法根权限,当前(以及任何早期)64位系统Linux在32位兼容模式下有一处漏洞,可以用来增强用户权限。举例说,来袭者可以闯入系统,利用Web服务器的一处漏洞获取受害系统的完全根权限(或称超级权限)或准入许可。

  据报道,问题出自32位的调用模拟层没有验证调用是否存在于系统调用表中。发现这一问题的Ben Hawkes说,这一隐患可以被用来以内核权限执行任意代码。目前已经有一个利用该漏洞的方法(可直接以源码形式下载)流通;在一个由The H的合作者在64位Ubuntu 10.04上实行的测试当中,它以根权限打开了一个shell。

  内核开发者已经在软件仓库纠正了这一瑕疵,Linux的发行厂商们了很可能近期会推出新的内核来关闭这一漏洞。那之前,如果你不必要这一功能的话,关闭32位ELF支持以解决这一问题。具体命令见:“应对Ac1db1tch3z漏洞”。

  Hawkes说,早在2007年,这一漏洞就被发现并被纠正了。但是在2008年的某个点上,开发者明显移除了那一补丁,再引入了漏洞。以前的入侵只需稍加改变就可以用在新的漏洞上。

作者:linux-ren.org责任编辑:王健)
请关注天极网天极新媒体 最酷科技资讯
扫码赢大奖
评论
* 网友发言均非本站立场,本站不在评论栏推荐任何网店、经销商,谨防上当受骗!
热点推荐
微软Windows 10操作系统Win10系统在Win8的基础上对界面、特性以及跨平台方面做了诸多优化。[详细]
Windows 10 新视界 [进入频道][使用技巧][微博互动]
手机整机DIY企业级